Entrypoint i4 System Requirements

Entrypoint i4 server and client applications run on any Windows, Mac or Unix operating system that supports the Java Runtime Environment (JRE) version 7.0.

Server

The Entrypoint i4 Server runs the WebClient, and includes system management and data entry functions. Requirements:

  • Single-core 2.8GHz processor or greater (recommended: 4–8 64-bit processor cores)
  • 2 GB RAM (recommended: 4–8GB RAM)
  • Runtime environment compatible with Java 7.0 (recommended: JRE 7 from java.com)
  • Java servlet container compatible with Servlet 2.5 (example: Apache Tomcat Version 6.0 or 7.0)
  • For data entry mode: any browser; recommended versions: Mozilla Firefox browser Version 5.0 or greater and the latest version of Chrome. If you are using Internet Explorer, we highly recommend Version 10.0 or later; previous versions have produced inconsistent results in the WebClient interface display. We also recommend updating to the latest version of whatever browser you choose to use.

Clients

Application Studio, the application developer's tool, and the Desktop System Manager and Desktop Workstation run locally. The Desktop System Manager includes much of the same functionality as the System Manager in the WebClient; in addition, operators can verify data, key from images and work offline. These local applications use the same database as the WebClient. Requirements for all:

  • Single-core 2.8GHz processor or greater (recommended: 4–8 64-bit processor cores)
  • 2 GB RAM (recommended: 4–8GB RAM)
  • Runtime environment compatible with Java 7.0

Databases

No third-party database system required to use the Derby database, which is easily embedded in the Apache Tomcat server environment.

Optional databases:

  • Microsoft SQL Server 2000 and above (requires Microsoft SQL Server JDBC driver)
  • MySQL 5.0 and above
  • MariaDB 5.5 and above


» Entrypoint